Mental Ray problemer

Diskusjoner, spørsmål, tips og triks

Moderatorer: Super Moderatorer, Admins

Brukeravatar

Trådstarter
Hjelvik
Innlegg: 139
Registrert: søn 23 jul, 2006

Legg innav Hjelvik » lør 07 apr, 2007

Ja, det skal gå bra. fikser problemene i morgen.

Brukeravatar

christerb
Innlegg: 3256
Registrert: man 24 apr, 2006
Sted: Oslo
Kontakt:

Legg innav christerb » lør 07 apr, 2007

ok. lykke til. :)

Brukeravatar

Trådstarter
Hjelvik
Innlegg: 139
Registrert: søn 23 jul, 2006

Legg innav Hjelvik » lør 07 apr, 2007

Jeg har ordnet opp i de problemene du nevnte, men jeg får likevel ikke rendra Jakka, boksa, og skulderbeskyttelses greia. Har du en anelse om hva det kommer av? Får den fatal error'n kun når jeg rendrer disse 2-3 tingene :/.

Brukeravatar

christerb
Innlegg: 3256
Registrert: man 24 apr, 2006
Sted: Oslo
Kontakt:

Legg innav christerb » lør 07 apr, 2007

Har du fjernet alle nGons og nonmanifold geometry? (og brukt cleanup og selection constraints for å sjekke?)
Jeg fikk til å rendre jakka.. testet som sagt bare med kroppen, jakka og buksa.

Jeg fikk hvertfall endel feilmeldinger ala denne da jeg prøvde å rendre buksa:
SURF 0.0 error 391081: invalid topology, quad face 9835

Brukeravatar

Trådstarter
Hjelvik
Innlegg: 139
Registrert: søn 23 jul, 2006

Legg innav Hjelvik » lør 07 apr, 2007

Ja, jeg har gjort det som du sier. wierd.

Brukeravatar

Trådstarter
Hjelvik
Innlegg: 139
Registrert: søn 23 jul, 2006

Legg innav Hjelvik » man 09 apr, 2007

Jeg har testa litt nå og har funnet ut at MR får fatal error dersom støvlene eller armoren er med. Får til å rendre jakka, boksa og karakteren, men dersom jeg rendrer hele figuren så får jeg erroren.
Jeg tror det er et eller annet subd objekt. Kanskje jeg er langt bortti svarte natta nå men.

Brukeravatar

christerb
Innlegg: 3256
Registrert: man 24 apr, 2006
Sted: Oslo
Kontakt:

Legg innav christerb » man 09 apr, 2007

Du kan jo prøve å gjøre de om til poly og eventuelt rendre med subDivApprox
istedenfor.
Vet ikke hvordan det er med MR 3.5, men med 3.4 funker det ikke med
nGons og subDivApprox.. det går å rendre, men objekter med nGons får
ikke subDiv.

Brukeravatar

Trådstarter
Hjelvik
Innlegg: 139
Registrert: søn 23 jul, 2006

Legg innav Hjelvik » søn 15 apr, 2007

Jeg har nå satt opp en SSS shader, og lagt den forige shaderen til side. Har ingen displacement enda, heller ingen cabity og normal map.

Har nå en bump map, specular map og vanlig color texture.
Likevel får jeg en veldig irriterende error som vanlig. Det er null problemer med shaderen, og selve modellen min har jeg kjørt cleanup på flere ganger. Rendrer foresten modellen uten klær og utstyr for å få så lang rendertid. Ingenting hjelper, og nå er jeg noen uker på etterskudd :/

Brukeravatar

Tormem
Innlegg: 885
Registrert: fre 02 nov, 2007
Sted: Olso
Kontakt:

Legg innav Tormem » søn 13 apr, 2008

Hei. Har ikke lest hele tråden, men dette er ihvertfall det jeg har gjort på den siste uka:

Zbrush 3.1 og Maya 8.5

1) Lager mesh i Maya
2) Sjekker for ngons med clean up mesh, optionboks, marker alle som ikke er quads
3) UV layout med pelting tools, sjekker for overlapping
4) Eksporterer fra maya med riktige innstillinger (dette har du gjort)
5) Importerer og bearbeider i Zbrush
6) Går til høyeste sub d, colour to texture, snur teksturen på hodet og eksporterer som psd
7) Går til tool jeg vil eksportere og setter laveste sub-d og eksporterer (har inntrykk av at høyere sub-d gir raskere displacement export og raskere mental ray render) som OBJ
8) Fortsatt i samme tool går jeg til tool > displacement > adaptive
9) Plug Ins > Multi displace Exporter, ingen map size adjust, 0-1 sub-pixel, 1024 eller 2048 px størrelse, trykker på settings: R32 og ok. Save som tif.
10) Gå hit:

http://www.zbrushcentral.com/zbc/showth ... rtfile.bat

..og lag batch-file som det står i tråden, finn displacement map og dra det over fila så får du en mental-ray vennlig .map-fil
11) Åpne psd-dokumentet i PS, korriger hva enn og save som tif, dra over filen igjen og få en ny .map fil
12) I maya velger du objektet, trykker ctrl+a og toggler av "feature displacement"
13) Sub-d approximation editor med objektet valgt, Sub-D tesselation (tror jeg, den i midten), standard settings med 2-4 ganger divide
14) Lag et material, dra displacement node over og velg "displacement", bestem displ. til å være en fil og finn teksturen din (du må forresten knytte materialet til objektet før du får lage displacement)
15) Sett teksturen til colour balance (nederst): Alpha Gain 2.2 og Alpha Offset til -1.1
16) Sett render settings til Mental Ray med "preview", lag egne lys om ønskelig og klem i vei.

Tror det var omtrent det. Jeg har som sagt akkurat overført en hel modell fra ZB til Maya, og render med alle sakene på (14 objekter m egne maps) tar ca 10-12 minutter.

Om du skal lage displacement på miSSS fast skin matierial må du velge matierialets shading group og dra displacment-noden over i øverste displacement-slot i attribute editor, ikke den under Custom Shaders. Det gir deg error.

Til slutt: Du får alltid en (unødvendig) warning når du bruker SSS om du har på lightmap: writable, da maya sier den finnes og blir overskrevet hver gang du renderer.

Håper du fant noe nyttig her, lykke til videre!

Brukeravatar

kbotnen
Innlegg: 356
Registrert: søn 15 jul, 2007
Sted: Bergen
Kontakt:

Legg innav kbotnen » man 14 apr, 2008

Nå har ikke jeg heller lest hele tråden, men jeg ser at det er et år siden sist det var aktivitet på den :) Vi feirer 1 års dagen på tirsdagen faktisk. Er det automagisk stenging av tråder på 3dhue? Sånn som det er på f.eks cgsociety, stenging etter 1 år med inaktivitet?

-K-

Brukeravatar

Tormem
Innlegg: 885
Registrert: fre 02 nov, 2007
Sted: Olso
Kontakt:

Legg innav Tormem » man 14 apr, 2008

HAHAHA! Jeg så ikke på årstall! Skrevet hele den essayen der fordi stakkars fyren hadde deadline... I FJOR!

Og i TILLEGG vekker jeg samboeren min klokken 3 i natt fordi jeg kommer på at det stod 16 April på posten hans, skjønner jeg ikke leverte timeliste den 15. og lurer panisk på hvordan jeg skal dekke husleia mi, hahahaha!

Brukeravatar

Kelemvor
Innlegg: 1221
Registrert: man 19 jun, 2006
Sted: Tønsberg
Kontakt:

Legg innav Kelemvor » man 14 apr, 2008

Hehehe.. Det er hva man kaller selveid.. :)

Brukeravatar

Pietas
Innlegg: 1412
Registrert: søn 16 apr, 2006
Sted: London

Legg innav Pietas » fre 18 apr, 2008

uansett så vil jeg påpeke en feil i forklaringen din :)

når du begynenr med polypainting så ødelegger du all uv på karakteren. du må først polypainte, så eksporterer, så importere obj med riktig uv før du kan trykke color>texture.
Du kan gjøre uv'en først, men det blir litt mer jobb

En ting som ofte skaper frusterasjon


Gå tilbake til «Mental Ray»

Hvem er online

Brukere i dette forumet: Ingen registrerte brukere og 1 gjest

cron